ihorizon - Platform Outage – Incident details

Platform Outage

Resolved
Operational
Started about 3 years agoLasted about 6 hours

Affected

app.ihorizon.co.uk

Operational from 10:36 AM to 4:41 PM

Updates
  • Resolved
    Resolved

    We’ve resolved the issue!

  • Monitoring
    Monitoring

    Affected users are currently unable to access any ihorizon products. Engineers are currently investigating this incident. We'll update the notice board here once we have more information.

  • Investigating
    Investigating

    Affected users are currently unable to access any ihorizon products. Engineers are currently investigating this incident. We'll update the notice board here once we have more information.