ihorizon - Issues connecting to services – Incident details
All systems operational
Issues connecting to services
Resolved
Major outage
Started over 3 years agoLasted about 7 hours
Updates
Resolved
Resolved
Our upstream provider has resolved the issue. Services are back to a healthy state. We'll continue monitoring.
Monitoring
Monitoring
Our upstream service provider is currently experiencing downtime with their EU cluster. Our team are monitoring the situation. Affected users are currently unable to access affected services.